summaryrefslogtreecommitdiff
path: root/dev-ruby/ritex/ritex-1.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ritex/ritex-1.0.1-r1.ebuild')
-rw-r--r--dev-ruby/ritex/ritex-1.0.1-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-ruby/ritex/ritex-1.0.1-r1.ebuild b/dev-ruby/ritex/ritex-1.0.1-r1.ebuild
index b7ddb95e158f..e4185dbe83ec 100644
--- a/dev-ruby/ritex/ritex-1.0.1-r1.ebuild
+++ b/dev-ruby/ritex/ritex-1.0.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README ReleaseNotes"
@@ -22,7 +22,9 @@ DEPEND+=" test? ( app-text/itex2mml )"
all_ruby_prepare() {
# Fix tests
- sed -i -e "s#\./itex2MML#/usr/bin/itex2MML#;142d" test/mathml.rb || die
+ sed -e "s#\./itex2MML#/usr/bin/itex2MML#;142d" \
+ -e 's/File.exists/File.exist/' \
+ -i test/mathml.rb || die
sed -i -e "12d" test/answer-key.yaml || die
}