summaryrefslogtreecommitdiff
path: root/dev-ruby/rinku/rinku-2.0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rinku/rinku-2.0.6-r1.ebuild')
-rw-r--r--dev-ruby/rinku/rinku-2.0.6-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rinku/rinku-2.0.6-r1.ebuild b/dev-ruby/rinku/rinku-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..c1d308f07202
--- /dev/null
+++ b/dev-ruby/rinku/rinku-2.0.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/rinku/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby library that does autolinking"
+HOMEPAGE="https://github.com/vmg/rinku"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' test/autolink_test.rb || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true ${RUBY} -Ilib test/autolink_test.rb || die
+}