summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild')
-rw-r--r--dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild
new file mode 100644
index 000000000000..2f06cc7c2317
--- /dev/null
+++ b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# Upstream has specs but they are not released and upstream is not tagged
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating Random identifier strings"
+HOMEPAGE="https://rubygems.org/gems/rex-random_identifier"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rex-text"