summaryrefslogtreecommitdiff
path: root/dev-ruby/rex-core/rex-core-0.1.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-core/rex-core-0.1.12.ebuild')
-rw-r--r--dev-ruby/rex-core/rex-core-0.1.12.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rex-core/rex-core-0.1.12.ebuild b/dev-ruby/rex-core/rex-core-0.1.12.ebuild
new file mode 100644
index 000000000000..b7aa58d0bcd6
--- /dev/null
+++ b/dev-ruby/rex-core/rex-core-0.1.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Core libraries required for the Ruby Exploitation(Rex) Suite"
+HOMEPAGE="https://rubygems.org/gems/rex-core"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}