summaryrefslogtreecommitdiff
path: root/dev-ruby/rest-client/rest-client-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rest-client/rest-client-2.1.0.ebuild')
-rw-r--r--dev-ruby/rest-client/rest-client-2.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/rest-client/rest-client-2.1.0.ebuild b/dev-ruby/rest-client/rest-client-2.1.0.ebuild
new file mode 100644
index 000000000000..8f973b66fd9c
--- /dev/null
+++ b/dev-ruby/rest-client/rest-client-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="history.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Simple HTTP and REST client for Ruby"
+HOMEPAGE="https://github.com/rest-client/rest-client"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/webmock:3 )"
+
+ruby_add_rdepend "
+ >=dev-ruby/http-accept-1.7.0:1
+ >=dev-ruby/http-cookie-1.0.2:0
+ >=dev-ruby/mime-types-1.16:* <dev-ruby/mime-types-4:*
+ >=dev-ruby/netrc-0.8:0
+"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' \
+ -e '/namespace :windows/,/^end/ s:^:#:' -i Rakefile || die
+
+ # Remove specs that requires network access.
+ rm spec/integration/{httpbin,request}_spec.rb || die
+}