summaryrefslogtreecommitdiff
path: root/dev-ruby/regexp_property_values
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/Manifest1
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/Manifest b/dev-ruby/regexp_property_values/Manifest
index d31dbb077bb8..264e13eedbfc 100644
--- a/dev-ruby/regexp_property_values/Manifest
+++ b/dev-ruby/regexp_property_values/Manifest
@@ -1,3 +1,4 @@
DIST regexp_property_values-1.0.0.tar.gz 12884 BLAKE2B 82f63d21a1e1508cef79afc2f1b5cca842c1e5bc96b197efa90ec0d02e7bd213cc67ae99f4f71cae6e632e0804fa2d6e935c7d30f27a940c767f5a83dd9edd21 SHA512 f51946d93c255c3b51bfb8055d2c0548c9656db9f208de74b569df8799fa97712a76b509546e149f71e3176ae0e979f295b225c171cedc687e1871f204c1e0d3
+EBUILD regexp_property_values-1.0.0-r1.ebuild 1136 BLAKE2B 03a34553868bb5f462fc72b9f50f430dd3ddd515dbee14b55ea118a813300253bac0b4064488ea89d8d7c67414aa5c0e8fe0b737e84b974d491b5cbb31bdd654 SHA512 6e849fd18abc2cb8b2e1a792bac4c3a995345e34cb8c509be9dde08257491c25869dd2efb5ace9d2ba984c45d55c594074533598a57c834c44ed8b2b13615924
EBUILD regexp_property_values-1.0.0.ebuild 1289 BLAKE2B ec4065e1c453911d25b680eb2160b4b9849f2a953dd6da79edba54be2ec5a1999d70235a0d89eb7575f54426d97b6091f5b02765f1570ae2cf54d583d397530a SHA512 7986377a69e583eaa00d914e590d58e6d718dc3b016260e0e0220e5fe82e20be208aebdea8a665f008888e0eaf87a2c3ca2472ebc0974bd0e046747bcd6e51bc
MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..c990f487d2b4
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/regexp_property_values/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/regexp_property_values"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
+SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/value_spec.rb || die
+}