summaryrefslogtreecommitdiff
path: root/dev-ruby/recog/recog-3.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/recog/recog-3.1.5.ebuild')
-rw-r--r--dev-ruby/recog/recog-3.1.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/recog/recog-3.1.5.ebuild b/dev-ruby/recog/recog-3.1.5.ebuild
new file mode 100644
index 000000000000..35ef2a4232d6
--- /dev/null
+++ b/dev-ruby/recog/recog-3.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="recog"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pattern recognition for hosts, services, and content"
+HOMEPAGE="https://github.com/rapid7/recog"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/nokogiri"
+
+ruby_add_bdepend "test? (
+ dev-ruby/regexp_parser
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}