summaryrefslogtreecommitdiff
path: root/dev-ruby/recog/recog-2.1.31.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/recog/recog-2.1.31.ebuild')
-rw-r--r--dev-ruby/recog/recog-2.1.31.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/recog/recog-2.1.31.ebuild b/dev-ruby/recog/recog-2.1.31.ebuild
new file mode 100644
index 000000000000..979c69af3ee8
--- /dev/null
+++ b/dev-ruby/recog/recog-2.1.31.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="xml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pattern recognition for hosts, services, and content"
+HOMEPAGE="https://github.com/rapid7/recog"
+
+LICENSE="BSD-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/nokogiri
+ !<dev-ruby/recog-2.0.6-r1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/regexp_parser
+ dev-ruby/rspec:3
+ dev-util/aruba
+ dev-util/cucumber
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec
+ ruby-ng_cucumber
+}