summaryrefslogtreecommitdiff
path: root/dev-ruby/rchardet/rchardet-1.8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rchardet/rchardet-1.8.0-r1.ebuild')
-rw-r--r--dev-ruby/rchardet/rchardet-1.8.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/rchardet/rchardet-1.8.0-r1.ebuild b/dev-ruby/rchardet/rchardet-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..fe5c2623afc6
--- /dev/null
+++ b/dev-ruby/rchardet/rchardet-1.8.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="rchardet.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Character encoding auto-detection in Ruby"
+HOMEPAGE="https://github.com/jmhodges/rchardet"
+SRC_URI="https://github.com/jmhodges/rchardet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}