summaryrefslogtreecommitdiff
path: root/dev-ruby/rbtree/rbtree-0.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rbtree/rbtree-0.4.4.ebuild')
-rw-r--r--dev-ruby/rbtree/rbtree-0.4.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/rbtree/rbtree-0.4.4.ebuild b/dev-ruby/rbtree/rbtree-0.4.4.ebuild
new file mode 100644
index 000000000000..546d735bd800
--- /dev/null
+++ b/dev-ruby/rbtree/rbtree-0.4.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTENSIONS=(./extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A sorted associative collection that is implemented with a Red-Black Tree"
+HOMEPAGE="https://rubygems.org/gems/rbtree"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} test.rb || die
+}