summaryrefslogtreecommitdiff
path: root/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild')
-rw-r--r--dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
index 9a971a876899..9b2217b37572 100644
--- a/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
+++ b/dev-ruby/rb-gsl/rb-gsl-2.1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23"
+USE_RUBY="ruby22 ruby23"
RUBY_FAKEGEM_NAME="gsl"
inherit ruby-fakegem multilib
@@ -36,6 +36,7 @@ all_ruby_prepare() {
each_ruby_configure() {
NARRAY=1 ${RUBY} -Cext/gsl_native extconf.rb || die
+ sed -i -e 's:-Wl,--no-undefined::' ext/gsl_native/Makefile || die
}
each_ruby_compile() {