summaryrefslogtreecommitdiff
path: root/dev-ruby/rack-protection/rack-protection-1.5.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack-protection/rack-protection-1.5.5.ebuild')
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.5.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/rack-protection-1.5.5.ebuild b/dev-ruby/rack-protection/rack-protection-1.5.5.ebuild
new file mode 100644
index 000000000000..947c453c7e41
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.5.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"