summaryrefslogtreecommitdiff
path: root/dev-ruby/plist/plist-3.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/plist/plist-3.7.1.ebuild')
-rw-r--r--dev-ruby/plist/plist-3.7.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/plist/plist-3.7.1.ebuild b/dev-ruby/plist/plist-3.7.1.ebuild
new file mode 100644
index 000000000000..c0b029420060
--- /dev/null
+++ b/dev-ruby/plist/plist-3.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to manipulate Property List files, also known as plists"
+HOMEPAGE="https://github.com/patsplat/plist"
+SRC_URI="https://github.com/patsplat/plist/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+ruby_add_rdepend "test? ( dev-ruby/base64 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}