summaryrefslogtreecommitdiff
path: root/dev-ruby/pdf-core/pdf-core-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pdf-core/pdf-core-0.10.0.ebuild')
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/pdf-core/pdf-core-0.10.0.ebuild b/dev-ruby/pdf-core/pdf-core-0.10.0.ebuild
new file mode 100644
index 000000000000..0e04f853bc04
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
+SRC_URI="https://github.com/prawnpdf/pdf-core/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1*
+ || ( dev-ruby/pdf-reader:2 >=dev-ruby/pdf-reader-1.2:0 )
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}