summaryrefslogtreecommitdiff
path: root/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild')
-rw-r--r--dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild b/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..66f65e8f38cf
--- /dev/null
+++ b/dev-ruby/paramesan/paramesan-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="paramesan.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parameterized tests in Ruby"
+HOMEPAGE="https://github.com/jpace/paramesan"
+
+SRC_URI="https://github.com/jpace/paramesan/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}