summaryrefslogtreecommitdiff
path: root/dev-ruby/omniauth
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/omniauth')
-rw-r--r--dev-ruby/omniauth/Manifest3
-rw-r--r--dev-ruby/omniauth/metadata.xml11
-rw-r--r--dev-ruby/omniauth/omniauth-1.8.1.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
new file mode 100644
index 000000000000..1b9217b18709
--- /dev/null
+++ b/dev-ruby/omniauth/Manifest
@@ -0,0 +1,3 @@
+DIST omniauth-1.8.1.tar.gz 26016 BLAKE2B ad7f22a847bd91385ddce44efc89fb312b07ffe43d2b0fab3773e7c809959eb8a8b4567af5ba1a1e9fb9d559b692dec358bf16d6b1cb21b85f13521c20fa3415 SHA512 ad085d067971f3fef40e99be7f2e58a9bb006b404f8d7289c5c00be4ed7314ff9d40409053d2bda0a5072035d6e09295d22b8ae6b5d2a84384b245b5a0ae225a
+EBUILD omniauth-1.8.1.ebuild 1227 BLAKE2B 3a016d30560b34e6104c14c7b6fcd174562b3c3fe544355edf579d0fdacc6634b4833cbccd352454a2ee7556e9dfd7fa4fc3b0495f3e240e1c0370478955a148 SHA512 6af2a8c090c162199aba4d81a990fb2686b970ad48ddf083e9c263a7e0c3d45476a0d60088567659ef75b741b16e9fd81a2caf59e71a74a5673676d6ad4cf129
+MISC metadata.xml 343 BLAKE2B eca1c20d937a878552be8bffd3394dc6a5b472b87a88f1ef2a096fd2ee75fe4feb343990c8e021bcc1144b6257175e2f8119ee374b6b551ebf19bcfc7860dd9d SHA512 189a7a11a84b2fa108299499e9f867768246b34237b74029eba64a0895d5c95d39544e340c4340cf50644f602411dfad991ff460c0269f1956061641e3cba130
diff --git a/dev-ruby/omniauth/metadata.xml b/dev-ruby/omniauth/metadata.xml
new file mode 100644
index 000000000000..ac37f7432587
--- /dev/null
+++ b/dev-ruby/omniauth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intridea/omniauth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/omniauth/omniauth-1.8.1.ebuild b/dev-ruby/omniauth/omniauth-1.8.1.ebuild
new file mode 100644
index 000000000000..2c597ca30306
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-1.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/rack-1.6.2:* <dev-ruby/rack-3:*
+ >=dev-ruby/hashie-3.4.6:3 <dev-ruby/hashie-3.6.0:3"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/RUBY_VERSION/,/^end/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}