summaryrefslogtreecommitdiff
path: root/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-ssh/net-ssh-4.2.0.ebuild')
-rw-r--r--dev-ruby/net-ssh/net-ssh-4.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild b/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
new file mode 100644
index 000000000000..0e07340d45b6
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="https://github.com/net-ssh/net-ssh"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="sodium test"
+
+ruby_add_rdepend "virtual/ruby-ssl sodium? ( dev-ruby/rbnacl:4 dev-ruby/bcrypt_pbkdf )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+all_ruby_prepare() {
+ # Don't use a ruby-bundled version of libsodium
+ sed -i -e '/rbnacl\/libsodium/ s:^:#:' lib/net/ssh/authentication/ed25519.rb || die
+
+ # Avoid bundler dependency
+ sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
+}