summaryrefslogtreecommitdiff
path: root/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-ssh/net-ssh-4.2.0.ebuild')
-rw-r--r--dev-ruby/net-ssh/net-ssh-4.2.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild b/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
deleted file mode 100644
index 89e2cbe7b45f..000000000000
--- a/dev-ruby/net-ssh/net-ssh-4.2.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
-RUBY_FAKEGEM_EXTRAINSTALL="support"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Non-interactive SSH processing in pure Ruby"
-HOMEPAGE="https://github.com/net-ssh/net-ssh"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="4"
-KEYWORDS="amd64 ~ppc ppc64 x86"
-IUSE="sodium test"
-
-ruby_add_rdepend "virtual/ruby-ssl sodium? ( dev-ruby/rbnacl:4 dev-ruby/bcrypt_pbkdf )"
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
-
-all_ruby_prepare() {
- # Don't use a ruby-bundled version of libsodium
- sed -i -e '/rbnacl\/libsodium/ s:^:#:' lib/net/ssh/authentication/ed25519.rb || die
-
- # Don' try to use libsodium-related tests with USE=-sodium
- if ! use sodium ; then
- rm -f test/authentication/test_ed25519.rb
- fi
-
- # Avoid bundler dependency
- sed -i -e '/\(bundler\|:release\)/ s:^:#:' Rakefile || die
-}