summaryrefslogtreecommitdiff
path: root/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-smtp/net-smtp-0.5.0.ebuild')
-rw-r--r--dev-ruby/net-smtp/net-smtp-0.5.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild b/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild
new file mode 100644
index 000000000000..8fe426c506ae
--- /dev/null
+++ b/dev-ruby/net-smtp/net-smtp-0.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+RUBY_FAKEGEM_GEMSPEC="net-smtp.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Mail Transfer Protocol client library for Ruby"
+HOMEPAGE="https://github.com/ruby/net-smtp"
+SRC_URI="https://github.com/ruby/net-smtp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend "
+ dev-ruby/net-protocol
+"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}