summaryrefslogtreecommitdiff
path: root/dev-ruby/necromancer/necromancer-0.7.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/necromancer/necromancer-0.7.0-r1.ebuild')
-rw-r--r--dev-ruby/necromancer/necromancer-0.7.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/necromancer/necromancer-0.7.0-r1.ebuild b/dev-ruby/necromancer/necromancer-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..a73aad34851d
--- /dev/null
+++ b/dev-ruby/necromancer/necromancer-0.7.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="necromancer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Conversion from one object type to another with a bit of black magic"
+HOMEPAGE="https://github.com/piotrmurach/necromancer"
+SRC_URI="https://github.com/piotrmurach/necromancer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}