summaryrefslogtreecommitdiff
path: root/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild')
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
index 7f7fa0d47fe6..463f215eb6d8 100644
--- a/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -14,7 +14,14 @@ LICENSE="MIT"
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
SLOT="0"
-IUSE=""
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -e 's/MiniTest::Unit::TestCase/Minitest::Test/' \
+ -i test/test_helper.rb test/test_nanotest.rb || die
+}
each_ruby_test() {
${RUBY} -I.:lib test/test_nanotest.rb || die