summaryrefslogtreecommitdiff
path: root/dev-ruby/mustermann/mustermann-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mustermann/mustermann-3.0.0.ebuild')
-rw-r--r--dev-ruby/mustermann/mustermann-3.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/mustermann/mustermann-3.0.0.ebuild b/dev-ruby/mustermann/mustermann-3.0.0.ebuild
new file mode 100644
index 000000000000..9c5d19b419c5
--- /dev/null
+++ b/dev-ruby/mustermann/mustermann-3.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# There are specs but they depend heavily on unpackaged code.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library implementing patterns that behave like regular expressions"
+HOMEPAGE="https://github.com/sinatra/mustermann"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/ruby2_keywords-0.0*"