summaryrefslogtreecommitdiff
path: root/dev-ruby/multipart-parser/multipart-parser-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/multipart-parser/multipart-parser-0.1.1.ebuild')
-rw-r--r--dev-ruby/multipart-parser/multipart-parser-0.1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/multipart-parser/multipart-parser-0.1.1.ebuild b/dev-ruby/multipart-parser/multipart-parser-0.1.1.ebuild
new file mode 100644
index 000000000000..a767d56f3529
--- /dev/null
+++ b/dev-ruby/multipart-parser/multipart-parser-0.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+#RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A multipart parser written in Ruby"
+HOMEPAGE="https://github.com/danabr/multipart-parser"
+#SRC_URI="https://github.com/lostisland/faraday-multipart/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )