summaryrefslogtreecommitdiff
path: root/dev-ruby/mocha/mocha-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mocha/mocha-2.2.0.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-2.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/mocha/mocha-2.2.0.ebuild b/dev-ruby/mocha/mocha-2.2.0.ebuild
new file mode 100644
index 000000000000..06d86dc2ac9b
--- /dev/null
+++ b/dev-ruby/mocha/mocha-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
+RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
+RUBY_FAKEGEM_GEMSPEC="mocha.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
+HOMEPAGE="https://mocha.jamesmead.org/"
+SRC_URI="https://github.com/freerange/mocha/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+ruby_add_rdepend ">=dev-ruby/ruby2_keywords-0.0.5"
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ export MOCHA_NO_DOCS=true
+ each_fakegem_test
+}