summaryrefslogtreecommitdiff
path: root/dev-ruby/mocha/mocha-1.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mocha/mocha-1.10.2.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-1.10.2.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/mocha/mocha-1.10.2.ebuild b/dev-ruby/mocha/mocha-1.10.2.ebuild
deleted file mode 100644
index 217ff4dd19c6..000000000000
--- a/dev-ruby/mocha/mocha-1.10.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
-
-RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
-HOMEPAGE="https://mocha.jamesmead.org/"
-
-LICENSE="MIT"
-SLOT="1.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-ruby_add_bdepend "
- test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
-}
-
-each_ruby_test() {
- export MOCHA_NO_DOCS=true
- each_fakegem_test
-}