summaryrefslogtreecommitdiff
path: root/dev-ruby/mocha/mocha-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mocha/mocha-0.14.0.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-0.14.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/mocha/mocha-0.14.0.ebuild b/dev-ruby/mocha/mocha-0.14.0.ebuild
new file mode 100644
index 000000000000..e8a0f25b3bae
--- /dev/null
+++ b/dev-ruby/mocha/mocha-0.14.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST="MOCHA_NO_DOCS=true test:units"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
+HOMEPAGE="http://gofreerange.com/mocha/docs/"
+
+LICENSE="MIT"
+SLOT="0.14"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
+
+ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+ sed -i -e '20irequire "mocha/setup"' test/test_helper.rb || die
+}