summaryrefslogtreecommitdiff
path: root/dev-ruby/memoizable/memoizable-0.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/memoizable/memoizable-0.4.2-r1.ebuild')
-rw-r--r--dev-ruby/memoizable/memoizable-0.4.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/memoizable/memoizable-0.4.2-r1.ebuild b/dev-ruby/memoizable/memoizable-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..5bc8fe628835
--- /dev/null
+++ b/dev-ruby/memoizable/memoizable-0.4.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Memoize method return values"
+HOMEPAGE="https://github.com/dkubb/memoizable"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/thread_safe-0.3.1:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/^end$/d" spec/spec_helper.rb || die
+
+ # Avoid a failing test that also fails for upstream Travis.
+ rm spec/unit/memoizable/class_methods/included_spec.rb || die
+}