summaryrefslogtreecommitdiff
path: root/dev-ruby/jwt/jwt-1.5.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/jwt/jwt-1.5.6.ebuild')
-rw-r--r--dev-ruby/jwt/jwt-1.5.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/jwt/jwt-1.5.6.ebuild b/dev-ruby/jwt/jwt-1.5.6.ebuild
new file mode 100644
index 000000000000..36ebaade1ca3
--- /dev/null
+++ b/dev-ruby/jwt/jwt-1.5.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.configure/,/^end/ s:^:#:' \
+ -e '/codeclimate/I s:^:#:' \
+ spec/spec_helper.rb || die
+}