summaryrefslogtreecommitdiff
path: root/dev-ruby/itextomml/itextomml-1.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/itextomml/itextomml-1.6.1.ebuild')
-rw-r--r--dev-ruby/itextomml/itextomml-1.6.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/itextomml/itextomml-1.6.1.ebuild b/dev-ruby/itextomml/itextomml-1.6.1.ebuild
new file mode 100644
index 000000000000..a6eb145fd8c5
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}