summaryrefslogtreecommitdiff
path: root/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild')
-rw-r--r--dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild b/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
new file mode 100644
index 000000000000..158cdf41c5d3
--- /dev/null
+++ b/dev-ruby/iobuffer/iobuffer-1.1.2-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit multilib ruby-fakegem
+
+GITHUB_USER="tarcieri"
+
+DESCRIPTION="IO::Buffer is a byte queue which is intended for non-blocking I/O applications"
+HOMEPAGE="https://github.com/tarcieri/iobuffer"
+SRC_URI="https://github.com/${GITHUB_USER}/iobuffer/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+all_ruby_prepare() {
+ rm .rspec lib/.gitignore Gemfile* || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die
+ sed -i -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" ext/Makefile || die
+}
+
+each_ruby_compile() {
+ emake -C ext V=1
+ cp ext/iobuffer_ext$(get_modname) lib/ || die
+}