summaryrefslogtreecommitdiff
path: root/dev-ruby/io-wait/io-wait-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/io-wait/io-wait-0.3.1.ebuild')
-rw-r--r--dev-ruby/io-wait/io-wait-0.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/io-wait/io-wait-0.3.1.ebuild b/dev-ruby/io-wait/io-wait-0.3.1.ebuild
new file mode 100644
index 000000000000..4c5293ff23a6
--- /dev/null
+++ b/dev-ruby/io-wait/io-wait-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS="ext/io/wait/extconf.rb"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="io-wait.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Waits until IO is readable or writable without blocking"
+HOMEPAGE="https://github.com/ruby/io-wait"
+SRC_URI="https://github.com/ruby/io-wait/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/task :test/ s:^:#:' -i Rakefile || die
+
+ # Avoid tests that require a working console
+ sed -e '/test_wait_mask_\(negative\|readable\|writable\|zero\)/aomit("Requires working console")' \
+ -i test/io/wait/test_io_wait.rb || die
+}