summaryrefslogtreecommitdiff
path: root/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild')
-rw-r--r--dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild b/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild
new file mode 100644
index 000000000000..6078251ff622
--- /dev/null
+++ b/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_GEMSPEC="immutable-ruby.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+# Releases are not tagged upstream
+COMMIT=84dba7382284fe7e85816a65abf5c2fc9bbc089e
+
+inherit ruby-fakegem
+
+DESCRIPTION="Efficient, immutable, thread-safe collection classes for Ruby"
+HOMEPAGE="https://github.com/immutable-ruby/immutable-ruby"
+SRC_URI="https://github.com/immutable-ruby/immutable-ruby/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.1:1
+ dev-ruby/sorted_set:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb spec/lib/immutable/vector/insert_spec.rb || die
+}