summaryrefslogtreecommitdiff
path: root/dev-ruby/idn-ruby/idn-ruby-0.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/idn-ruby/idn-ruby-0.1.2.ebuild')
-rw-r--r--dev-ruby/idn-ruby/idn-ruby-0.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/idn-ruby/idn-ruby-0.1.2.ebuild b/dev-ruby/idn-ruby/idn-ruby-0.1.2.ebuild
new file mode 100644
index 000000000000..56707f390fe9
--- /dev/null
+++ b/dev-ruby/idn-ruby/idn-ruby-0.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="LibIDN Ruby Bindings"
+HOMEPAGE="https://github.com/deepfryed/idn-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" net-dns/libidn:0"
+DEPEND+=" net-dns/libidn:0"
+
+all_ruby_prepare() {
+ # Avoid UTF-8 tests since we cannot guarantee a UTF-8 environment
+ rm -f test/tc_Stringprep.rb || die
+}
+
+each_ruby_prepare() {
+ mkdir lib || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*.rb"].each{|f| require f}' || die
+}