summaryrefslogtreecommitdiff
path: root/dev-ruby/http-parser/http-parser-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/http-parser/http-parser-1.2.3.ebuild')
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.3.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-ruby/http-parser/http-parser-1.2.3.ebuild b/dev-ruby/http-parser/http-parser-1.2.3.ebuild
deleted file mode 100644
index 179dcdf621ab..000000000000
--- a/dev-ruby/http-parser/http-parser-1.2.3.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A super fast http parser for ruby"
-HOMEPAGE="https://github.com/cotag/http-parser"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE=""
-
-DEPEND+=" >=net-libs/http-parser-2.8.1"
-RDEPEND+=" >=net-libs/http-parser-2.8.1"
-
-ruby_add_bdepend "dev-ruby/ffi-compiler"
-
-each_ruby_compile() {
- ${RUBY} -C ext -S rake || die
- mv ext/*/libhttp-parser-ext.so lib/http-parser/ || die
-}