summaryrefslogtreecommitdiff
path: root/dev-ruby/hiera/hiera-3.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hiera/hiera-3.2.2.ebuild')
-rw-r--r--dev-ruby/hiera/hiera-3.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/hiera/hiera-3.2.2.ebuild b/dev-ruby/hiera/hiera-3.2.2.ebuild
new file mode 100644
index 000000000000..5004cab72e13
--- /dev/null
+++ b/dev-ruby/hiera/hiera-3.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="https://docs.puppet.com/hiera/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 hppa ppc x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/deep_merge"