summaryrefslogtreecommitdiff
path: root/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild')
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
deleted file mode 100644
index bee2082459ac..000000000000
--- a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
-DESCRIPTION="Removes leading whitespace from Ruby heredocs"
-HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}