summaryrefslogtreecommitdiff
path: root/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild')
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..c34fd046a74d
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}