summaryrefslogtreecommitdiff
path: root/dev-ruby/grpc/grpc-1.59.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/grpc/grpc-1.59.2.ebuild')
-rw-r--r--dev-ruby/grpc/grpc-1.59.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-ruby/grpc/grpc-1.59.2.ebuild b/dev-ruby/grpc/grpc-1.59.2.ebuild
index 934ddf075b4a..931429078487 100644
--- a/dev-ruby/grpc/grpc-1.59.2.ebuild
+++ b/dev-ruby/grpc/grpc-1.59.2.ebuild
@@ -8,7 +8,7 @@ RUBY_FAKEGEM_EXTENSIONS=(src/ruby/ext/grpc/extconf.rb)
RUBY_FAKEGEM_EXTRAINSTALL="etc src"
RUBY_FAKEGEM_RECIPE_TEST="none"
-inherit ruby-fakegem
+inherit multiprocessing ruby-fakegem
DESCRIPTION="Send RPCs from Ruby using GRPC"
HOMEPAGE="https://github.com/grpc/grpc"
@@ -23,6 +23,12 @@ ruby_add_rdepend "
>=dev-ruby/google-protobuf-3.24.4
"
+each_ruby_configure() {
+ export GRPC_RUBY_BUILD_PROCS="$(makeopts_jobs)"
+
+ each_fakegem_configure
+}
+
each_ruby_install() {
# Remove all the "src" bits that are not needed
rm -rf src/core src/ruby/spec src/ruby/ext/grpc/{libs,objs} || die