summaryrefslogtreecommitdiff
path: root/dev-ruby/git/git-1.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/git/git-1.19.1.ebuild')
-rw-r--r--dev-ruby/git/git-1.19.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/git/git-1.19.1.ebuild b/dev-ruby/git/git-1.19.1.ebuild
index 36d7c68160a4..bbf958a96748 100644
--- a/dev-ruby/git/git-1.19.1.ebuild
+++ b/dev-ruby/git/git-1.19.1.ebuild
@@ -18,7 +18,7 @@ RUBY_S="ruby-git-${PV}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
IUSE="test"
DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
@@ -33,6 +33,9 @@ all_ruby_prepare() {
sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
sed -i -e 's/__dir__/"."/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Don't use deprecated key type that is removed from openssh
+ sed -i -e 's/-t dsa/-t rsa/' tests/units/test_signed_commits.rb || die
}
each_ruby_test() {