summaryrefslogtreecommitdiff
path: root/dev-ruby/gist/gist-5.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/gist/gist-5.0.0.ebuild')
-rw-r--r--dev-ruby/gist/gist-5.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/gist/gist-5.0.0.ebuild b/dev-ruby/gist/gist-5.0.0.ebuild
new file mode 100644
index 000000000000..f5655faac28f
--- /dev/null
+++ b/dev-ruby/gist/gist-5.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Potentially the best command line gister."
+HOMEPAGE="https://github.com/defunkt/gist"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-python/txgithub also installs a 'gist' binary.
+RDEPEND="!dev-python/txgithub"