summaryrefslogtreecommitdiff
path: root/dev-ruby/flog/flog-4.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/flog/flog-4.8.0.ebuild')
-rw-r--r--dev-ruby/flog/flog-4.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/flog/flog-4.8.0.ebuild b/dev-ruby/flog/flog-4.8.0.ebuild
new file mode 100644
index 000000000000..cd806a4de441
--- /dev/null
+++ b/dev-ruby/flog/flog-4.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flog reports the most tortured code in an easy to read pain report"
+HOMEPAGE="https://ruby.sadi.st/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend "
+ dev-ruby/path_expander:1
+ >dev-ruby/ruby_parser-3.1.0:3
+ >=dev-ruby/sexp_processor-4.8:4"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_flog.rb || die
+}