summaryrefslogtreecommitdiff
path: root/dev-ruby/fiber-annotation
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fiber-annotation')
-rw-r--r--dev-ruby/fiber-annotation/Manifest3
-rw-r--r--dev-ruby/fiber-annotation/fiber-annotation-0.2.0.ebuild28
-rw-r--r--dev-ruby/fiber-annotation/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/fiber-annotation/Manifest b/dev-ruby/fiber-annotation/Manifest
new file mode 100644
index 000000000000..1cecbb672ce8
--- /dev/null
+++ b/dev-ruby/fiber-annotation/Manifest
@@ -0,0 +1,3 @@
+DIST fiber-annotation-0.2.0.tar.gz 5743 BLAKE2B 87ab3601f53ecbac05ed251438b95f10d26078d319ced6fcde6e1b9c96d58bcbd5c8d5e9e15325f54c32543b61e91ce53f02964aacb8afc57d7636aa70597007 SHA512 d030ad1a3824ea2e7b31781ed31aa1fba187c44479351fb21911ade090f8596b38f5b6352420b26df705d12b086421b78a4987590169a33550de1ed565630e87
+EBUILD fiber-annotation-0.2.0.ebuild 721 BLAKE2B de4a503123a1f54aa9b53921a29af927a33a8df162977b8f0cb9bdd4bc716b9529b07492f303df8885803592e84bed86ccbd1c974072d84bd4907f144e72a06e SHA512 4898afabf287f7b6d01eb84a1832282221c96cdd3038e7b0e49853a412f54cab3c3d96ba0ab4575f09d004e9bfb371d14099a4d4058fbaf33927bdc96e292565
+MISC metadata.xml 412 BLAKE2B 3adae6eb3a314949c424f07301b9810f2e23a01437fb49e46c93fee1f12013230919817b917f6658ed3090d2c759cb102bda51e6d813030a6d93835f7d309db2 SHA512 cb1e3d7242ac7f93cd8435285a4f381e576fd023ee2711bbfe56be413f58700b7cfd9568b371b9f43505596fbd8a10ff4fcd9b293179d2db9307959873e4279b
diff --git a/dev-ruby/fiber-annotation/fiber-annotation-0.2.0.ebuild b/dev-ruby/fiber-annotation/fiber-annotation-0.2.0.ebuild
new file mode 100644
index 000000000000..5ba21af36201
--- /dev/null
+++ b/dev-ruby/fiber-annotation/fiber-annotation-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A mechanism for annotating fibers"
+HOMEPAGE="https://github.com/ioquatix/fiber-annotation"
+SRC_URI="https://github.com/ioquatix/fiber-annotation/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid unpackaged sus covered
+ rm -f config/sus.rb
+}
diff --git a/dev-ruby/fiber-annotation/metadata.xml b/dev-ruby/fiber-annotation/metadata.xml
new file mode 100644
index 000000000000..c20327fbd2e4
--- /dev/null
+++ b/dev-ruby/fiber-annotation/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ioquatix/fiber-annotation</remote-id>
+ <remote-id type="rubygems">fiber-annotation</remote-id>
+ </upstream>
+</pkgmetadata>