summaryrefslogtreecommitdiff
path: root/dev-ruby/dotenv/dotenv-2.7.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/dotenv/dotenv-2.7.6.ebuild')
-rw-r--r--dev-ruby/dotenv/dotenv-2.7.6.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/dotenv/dotenv-2.7.6.ebuild b/dev-ruby/dotenv/dotenv-2.7.6.ebuild
deleted file mode 100644
index 31eb7242b75a..000000000000
--- a/dev-ruby/dotenv/dotenv-2.7.6.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26"
-
-RUBY_FAKEGEM_EXTRADOC="README.md Changelog.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Loads environment variables from .env into ENV"
-HOMEPAGE="https://github.com/bkeepers/dotenv"
-SRC_URI="https://github.com/bkeepers/dotenv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/spring dev-ruby/rails )"
-
-all_ruby_prepare() {
- sed -i -e '/:guard/,/end/ s:^:#:' \
- -e '5igem "rspec", "~> 3.0"' Gemfile || die
-
- sed -i -e '/rubocop/ s:^:#:' -e 's/git ls-files/find/' dotenv.gemspec || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:ruby -v:${RUBY} -v:g" spec/dotenv/parser_spec.rb || die
-}