summaryrefslogtreecommitdiff
path: root/dev-ruby/debug/debug-1.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/debug/debug-1.7.1.ebuild')
-rw-r--r--dev-ruby/debug/debug-1.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/debug/debug-1.7.1.ebuild b/dev-ruby/debug/debug-1.7.1.ebuild
new file mode 100644
index 000000000000..6dc149fdd96d
--- /dev/null
+++ b/dev-ruby/debug/debug-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="TODO.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/debug/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/debug"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Debugging functionality for Ruby"
+HOMEPAGE="https://github.com/ruby/debug"
+SRC_URI="https://github.com/ruby/debug/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="$(ver_cut 1)"
+
+# Avoid tests for now since the results in a very deep dependency list for ruby32
+#ruby_add_depend "test? ( dev-ruby/rr )"
+RESTRICT="test"
+
+all_ruby_prepare() {
+ sed -i -e "s:require_relative ':require './:" -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}