summaryrefslogtreecommitdiff
path: root/dev-ruby/ddmemoize/ddmemoize-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ddmemoize/ddmemoize-1.0.0.ebuild')
-rw-r--r--dev-ruby/ddmemoize/ddmemoize-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ddmemoize/ddmemoize-1.0.0.ebuild b/dev-ruby/ddmemoize/ddmemoize-1.0.0.ebuild
new file mode 100644
index 000000000000..a7cf081b5e5d
--- /dev/null
+++ b/dev-ruby/ddmemoize/ddmemoize-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds support for memoizing functions"
+HOMEPAGE="https://github.com/ddfreyne/ddmemoize/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/ddmetrics:1
+ dev-ruby/ref:2
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^SimpleCov.formatter/ s:^:#:' \
+ -e '/fuubar/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}