summaryrefslogtreecommitdiff
path: root/dev-ruby/date/date-3.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/date/date-3.3.1.ebuild')
-rw-r--r--dev-ruby/date/date-3.3.1.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/date/date-3.3.1.ebuild b/dev-ruby/date/date-3.3.1.ebuild
deleted file mode 100644
index 303b2f58e831..000000000000
--- a/dev-ruby/date/date-3.3.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTENSIONS=(ext/date/extconf.rb)
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_GEMSPEC="date.gemspec"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A subclass of Object includes Comparable module for handling dates"
-HOMEPAGE="https://github.com/ruby/date"
-SRC_URI="https://github.com/ruby/date/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-all_ruby_prepare() {
- sed -e 's/__dir__/"."/' \
- -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
- -e 's/git ls-files -z/find * -print0/' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
-}