summaryrefslogtreecommitdiff
path: root/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild')
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..919687207be3
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to start and stop specific daemons programmatically in a robust manner"
+HOMEPAGE="https://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}