summaryrefslogtreecommitdiff
path: root/dev-ruby/console/console-1.16.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/console/console-1.16.2.ebuild')
-rw-r--r--dev-ruby/console/console-1.16.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/console/console-1.16.2.ebuild b/dev-ruby/console/console-1.16.2.ebuild
new file mode 100644
index 000000000000..9d18391d436f
--- /dev/null
+++ b/dev-ruby/console/console-1.16.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Beautiful logging for Ruby"
+HOMEPAGE="https://github.com/socketry/console"
+SRC_URI="https://github.com/socketry/console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/fiber-local"
+
+ruby_add_bdepend "test? ( dev-ruby/sus )"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on covered.
+ rm -f config/sus.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S sus || die
+}