summaryrefslogtreecommitdiff
path: root/dev-ruby/color/color-1.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/color/color-1.8-r1.ebuild')
-rw-r--r--dev-ruby/color/color-1.8-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/color/color-1.8-r1.ebuild b/dev-ruby/color/color-1.8-r1.ebuild
new file mode 100644
index 000000000000..64f4215a36c2
--- /dev/null
+++ b/dev-ruby/color/color-1.8-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+RUBY_FAKEGEM_GEMSPEC="color.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Colour management with Ruby"
+HOMEPAGE="https://github.com/halostatue/color"
+SRC_URI="https://github.com/halostatue/color/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.0
+ )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}