summaryrefslogtreecommitdiff
path: root/dev-ruby/childprocess/childprocess-0.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/childprocess/childprocess-0.5.3.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.3.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.5.3.ebuild b/dev-ruby/childprocess/childprocess-0.5.3.ebuild
deleted file mode 100644
index e14792bb15fb..000000000000
--- a/dev-ruby/childprocess/childprocess-0.5.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Solution for controlling external programs running in the background"
-HOMEPAGE="https://github.com/jarib/childprocess"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sparc x86"
-IUSE=""
-
-ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:2 )"
-
-ruby_add_rdepend "virtual/ruby-ffi"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
- sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}